Omri Aharon

Why Overwolf Might Not show up in your game

Recommended Posts

Hey fellas,

I'm going to write down some of the reasons you might be experiencing difficulties with Overwolf.
I'll update this post as we go along.

1) For some users the cause might be that you do not have DirectX Runtime installed (needed because we added support to DirectX11). This is an extension to your DirectX library. Please Install from this link and it will most likely solve your problem. 

2) Xfire overlay and Overwolf conflict - May cause crashes and other performance issues.

3) The game you are trying to use Overwolf with is not supported by us. You can check this by checking the list located in Settings->Games or by checking this link here

4) PunkBuster - another conflict. We are trying to resolve it with them, but for the moment it is a problem.

5) You do not have .NET 3.5 or .NET 4 installed. See to it :-)

6) Rare - but might happen. We currently do not supported DirectX10. If you suspect this might be the issue, check our supported game list. we note each DirectX10 game and also how to change it so that Overwolf will work.

edited by illy b @ overwolf team

Share this post


Link to post
Share on other sites

also, my bad company 2 crashed everytime i try and join a server

regardless of me having xfire or steam on or off. even regardless to the DirectX version.

if i exit overwolf and launch the game, my game doesn't crash when i join a server.

overwolf is a great thing, it just needs better support for games like this! :)

Share this post


Link to post
Share on other sites

Ok sounds like we need to dig deeper to understand these issues.

Please try again to use the game in DX9 with overwolf and try again to join a server at BC2.

Then sends us a log report so we can understand what happend. To do so, just open Overwolf, enter the settings screen by clicking on the small wrench icon and there on the general tab click on "Tell us about a problem".

A send log window will open, there write something so I'll know its you among all other reports we get and hit send.

Thanks a million!!!!

Share this post


Link to post
Share on other sites

I've tryed all that you mentioned and still it wont show up in World of warcraft and it also makes my World of warcraft to crash with error 132, and thats a memory error according to blizzard. I did send a email about this and my logs are in it.

Hope you guys find a solution for this!

Share this post


Link to post
Share on other sites
I've tryed all that you mentioned and still it wont show up in World of warcraft and it also makes my World of warcraft to crash with error 132, and thats a memory error according to blizzard. I did send a email about this and my logs are in it.

Hope you guys find a solution for this!

To which email address did you sent it too?

Share this post


Link to post
Share on other sites

However the bug have changed before wow went off with a error now world of warcraft just shuts down no error nothing, but i cant get Overwolf to work :( since i use fullscreen it would be awsome to have

Share this post


Link to post
Share on other sites
However the bug have changed before wow went off with a error now world of warcraft just shuts down no error nothing, but i cant get Overwolf to work :( since i use fullscreen it would be awsome to have

Can you please send me Overwolf logs with a link to this thread?

How to send Overwolf logs:

Go to "Start" > Search for %localappdata% > Make a RAR File from the Overwolf file > Send to this email: asaf.livne@overwolf.com

Thank you,

Team Overwolf.

Share this post


Link to post
Share on other sites

I've been trying all types of things to get Overwolf working on League of Legends but it doesn't seem to work. Does overwolf automaticly show on the middle left like it does at windows desktop in-game or do you have to press something in-game inorder to get overwolf widgets to show upp?

Updated 10mins Later -

I Tried using overwolf again on World of Warcraft because it looked like it would work easyier on that and it always seems to work on WoW

for people. I Tried it didn't work. I Tried using it without xfire with it, and restarted Overwolf, Tried using Overwolf as admin. Doesn't seem to work.

Share this post


Link to post
Share on other sites

Can you please send me the logs?

How to send Overwolf logs:

Go to "Start" > Search for %localappdata% > Search and enter to Overwolf directory > Search for Log directory > Make a RAR File from the Log file > Send to this email: asaf.livne@overwolf.com

After that, please delete Overwolf localappdata and try aqgain. BUT you have to send me the logs before.

Thank you :)

Share this post


Link to post
Share on other sites
Can you please send me the logs?

How to send Overwolf logs:

Go to "Start" > Search for %localappdata% > Search and enter to Overwolf directory > Search for Log directory > Make a RAR File from the Log file > Send to this email: asaf.livne@overwolf.com

After that, please delete Overwolf localappdata and try aqgain. BUT you have to send me the logs before.

Thank you :)

I Tried making the log file into a rar file but it gives me errors like cannot find etc. Do you want the log file into a rar file or everything within the log file INTO a rar file. i don't really understand lol. Also it looks like msi afterburner might be the problem honestly. Is msi afterburner supported with overwolf if not i'm uninstalling until that is fixed. But if not please help thx!

Share this post


Link to post
Share on other sites

Program installs fine and runs flawless under windows (as far as I can see, never crashed or anything anyways and responds fine when playing with it in windows) but will not under any conditions show up ingame.

DirectX Runtime Installed from ur link (already had it), No Xfire on my computer at all, several games supported by overwolf tried (as EVE online, StarCraft 2, Left 4 dead 2 and so on), deactivated the punkbuster service, .net 3.5 is part of windows 7 so that one I have, Installed the .net 4, Tried several games as stated with dx9,dx10 and dx11 and still no go.

Also tried to only run with one screen instead of two, ran the program as administrator, tried running the games in windowed mode and fullscreen, deactivated my NOD32 completly and it still wont show up in anygame whatsoever. Only once for some weird reason did it work when I played Eve Online but never since.

Soooooo Im stuck and need some help. Ohh on Windows 7 64bit running two nvidia GTX460 on SLI if that can mess it up for some dang it if I know reason. :cry:

*edit*

And yes I have tried the shortcuts to show hide overwolf ingame and even changed the shortcuts to something else and tried again but still no go :? Tried grabbing screenshots ingame (even without overwolf showing) but it wont work either so... halp

Share this post


Link to post
Share on other sites

I'm having the same problem as Sultan but I'm using the Enjin version of it.

I did everything that was in the OP as well as turning off FRAPS and EVGA Precision. Also, the Shift + Tab function will not work on Steam while this is working in the background like what the Second Post mentioned. I've also sent in a Bug Report as well as posting on the official Enjin forum for this client.

Share this post


Link to post
Share on other sites

Hi, I just found the reasond of your problem.

Overwolf for some reason does not support Teamspeak 3 64-bit version and World of Warcraft 64-bit version.

I don't know about any other game but there will be several of them :-)

It is really bad because when I should use WoW 32-bit version along with TS 32-bit version on my 64-bit windows 7

I will lost a lot of fps regardless of what I was doing :(

Please fix/remake it, it would extremely increase my good experience using overwolf :o

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now