Ome

Replays not capturing audio

Recommended Posts

Ome    0

I'm trying to figure out why captures have no audio. Below are my settings:

overwolf.media.replays.turnOn({
    "settings": {
        "audio": {
            "mic": {
                "volume": micVolume
            },
            "game": {
                "volume": gameVolume
            }
        }
    }        
}, function(status) {
    // TODO
});	

Both system and microphone audio are enabled in the capture settings. I've tried adding the "enabled" property, but nothing changes. I'm also sure that both variables != 0. Am I missing something?

Edited by Ome

Share this post


Link to post
Share on other sites
Ome    0

There were some audio issues previously. We'll push 90.208 today, please check if that version solves your issue.

If not, post back and we'll look further into it.

 

Hey Viking, quick update. If I remove the settings, audio is captured fine. I'm on the latest Overwolf build (90.208).

Share this post


Link to post
Share on other sites
Ome    0

I'll assume the "micVolume" and "gameVolume" are replaced by numbers, as volume takes an int between 0 and 100.

Also, perhaps try and add the device_id and see if that works.

 

I tried adding a device ID - it's a no go. I'll keep playing with it, and if anything, I'll just remove them for the time being.

Share this post


Link to post
Share on other sites
Ome    0

Thanks for the update, will ask our devs to have a look at it.

 

Edit: Bug on our part - setting the volume will botch it. Added to our next version's tasks.

 

Glad you found the issue. Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now